0

SendEmail funktioniert seid gestern wieder nicht

Hallo zusammen, hat jemand ähnliches Verhalten.

Wir sende unsere Berichte über SendEmail die gehen anscheinend auch raus kommen aber nicht an.

???

Problem war in letzter Zeit schon öfters.

Wurde dann aber gefixt.

Weiß jemand woran das liegt?

13 Antworten

null
    • W. H. Fischer Zentralschmiertechnik GmbH
    • Administrator.1
    • vor 1 Monat
    • Gemeldet - anzeigen

    Ich habe das gleiche Problem,

    es kommt immer die Fehlermeldung [object Object].

    Die Zeile html: … habe ich bereits hinterlegt.

      • UweG
      • vor 1 Monat
      • Gemeldet - anzeigen


      Kannst du vielleicht ein Screenshot der Fehlermeldung reinstellen?
      Wie sieht denn das Script für sendEmail aus?
      Ich habe folgendes getestet und die Mail kommt an, zwar in meinem Spam aber sie kommt an inkl. Anhang.
      sendEmail({
          from: Von,
          to: An,
          replyTo: AntwortAdresse,
          subject: Betreff,
          text: SendText,
          html: "",
          attachments: files(this)
      })

      • Rafael_Sanchis
      • vor 1 Monat
      • Gemeldet - anzeigen

       

      Hi UweG

      My problem.

      let check := dialog(" Monthly Report ", " Confirm the sending of this email...> ", ["Do Not Send", "Yes Send"]);
      if check = "Yes Send" then
          sendEmail({
              from: userEmail(user()),
              to: "rafael.sanchis@gmail.com",
              cc: "rafael.sanchis@gmail.com",
              subject: " Send Monthy Report ",
              text: " Please see attached  Monthly Report / Progress, Cost & Hours / 17/Mayo/2024",
              attachments: "Cost Report"
          })
      end
      
      
      • UweG
      • vor 1 Monat
      • Gemeldet - anzeigen

       html-key is missing in the sendEmail-Object.

      Try:
       

      let check := dialog(" Monthly Report ", " Confirm the sending of this email...> ", ["Do Not Send", "Yes Send"]);
      if check = "Yes Send" then
          sendEmail({
              from: userEmail(user()),
              to: "rafael.sanchis@gmail.com",
              cc: "rafael.sanchis@gmail.com",
              subject: " Send Monthy Report ",
              text: " Please see attached  Monthly Report / Progress, Cost & Hours / 17/Mayo/2024",
             html: "";
              attachments: "Cost Report"
          })
      end

      • W. H. Fischer Zentralschmiertechnik GmbH
      • Administrator.1
      • vor 1 Monat
      • Gemeldet - anzeigen

      Hi,

      hier der Script. Ich habe es gerade eben getestet, funktionierte beim ersten senden sofort wieder ??????

      Es wurde auch nichts Verändert, schon komisch.

      'wurde gesendet am' := today();
      let DateiAnhang := importFile(this, printAndSaveRecord(this, "Gestalltet"), "Angebot ZSA " + Nr + "Mail.pdf");
      sendEmail({
          from: "mail@whfischer.de",
          to: EMail,
          cc: 'in CC',
          bcc: "mail@whfischer.de",
          subject: 'Betrifft Zeile',
          text: 'Text E-Mail',
          html: 'Text E-Mail',
          attachments: files(this),
      })

    • UweG
    • vor 1 Monat
    • Gemeldet - anzeigen

    Sorry komma instead of semicolon.

      • Rafael_Sanchis
      • vor 1 Monat
      • Gemeldet - anzeigen

       Thanks Now send the message 👍 

    • Heinrich Frey Maschinenbau GmbH
    • Christian_Rott
    • vor 1 Monat
    • Gemeldet - anzeigen

    Danke für den Tip. Jetzt funktioniert es wieder.

    Was ich aber nicht verstehe ist das es die letzten Wochen immer ging. Auch ohne den

    html:"", ???

      • UweG
      • vor 1 Monat
      • Gemeldet - anzeigen

       
      Man kann ja bei sendMail() Inhalte sowohl als plain Text oder html mitsenden.
      Bisher wurde das Vorhandensein wohl nicht geprüft.
      Jetzt haben die Entwickler von Ninox haben wohl mit dem letzten Ninox Update die Notwendigkeit des vorhanden seins des html-Eintrags in der sendEmail()-Funktion verankert, so wie bspw. der Betreff.
      Deshalb die Fehlermeldung des fehlenden 'html'.

      • Heinrich Frey Maschinenbau GmbH
      • Christian_Rott
      • vor 1 Monat
      • Gemeldet - anzeigen

       Danke für die Info. Was bei mir uns aufgefallen ist das diese Fehlermeldung nur im Browser kommt. Die meisten von uns in der Firma arbeiten mit iPads die sie Abends im WLAN dann die Berichte versenden doch da kommt keine Fehlermeldung. Was die Sache dann noch etwas erschwert hat bis man dahinter kam das die Berichte nicht ankommen.

      • UweG
      • vor 1 Monat
      • Gemeldet - anzeigen

       Die Browserversion ist v3.12.3, die App ist noch auf v3.12.2.
      App v3.12.3 muss erst noch durch den App Store frei gegeben werden.

      • Rafael_Sanchis
      • vor 1 Monat
      • Gemeldet - anzeigen

       

      On Android now is on 3.12.3

      • UweG
      • vor 1 Monat
      • Gemeldet - anzeigen

       I mean the Apple Apps and there are different in Mac and iPhone/iPad Apps.
      It's not possible to update all apps at the same time. So there are differenst in App versions which are available.

Content aside

  • Status Answered
  • vor 1 MonatZuletzt aktiv
  • 13Antworten
  • 90Ansichten
  • 4 Folge bereits